Tagged: macbook Toggle Comment Threads | Keyboard Shortcuts

  • danielsaidi 8:11 am on January 28, 2010 Permalink | Reply
    Tags: macbook,   

    MagSafe toggles green/orange (cont.) 

    I have some strange updates regarding the greeen/orange blinking MagSafe I wrote about yesterday.

    As I wrote, the LED on the MagSafe blinks between loaded (green) and loading (orange) even though my new battery is fully loaded.

    When I tried the battery in a friend’s computer, it worked…and while trying the battery at her place, it worked even in mine! Yet, when I returned home, the blinking re-appeared…and even continued when I tried another MagSafe connector. Straaaange times.

    However, an even stranger thing has happened since then. Before going to bed yesterday (after reading about exploding, blinking MagSafe connectors for hours) I decided to try installing OS X upgrades. They said something abot adjusting the computer for new hardware (strange) and then I shut it down for the night.

    When I started the computer this morning, the blinking had stopped! Either, my MagSafe connector is loose and the other I tried is loose or broken as well (quite unlikely), or I just had to install additional drivers for the battery. I do not understand a thing, but as long as the blinking have stopped, I am mr. Happy.

    Update: Now, at 10:30 am, the LED is blinking once again. It seems like the LED does not blink when I have had the MagSafe disconnected for a while…but since my neighbor’s MagSafe blinked with my computer, it seems to be an issue with either the computer or the battery.

     
    • Ergon 11:24 pm on November 9, 2011 Permalink | Reply

      Just a quick not for anyone who might be reading this down the track, a blinking green/amber light on your magsafe adapter can mean one of a few things.

      The error message itself is that power is not getting to the battery or logic board.

      Possible causes to this problem are:
      -Broken magsafe adapter
      -Faulty battery
      -Needs a replacement DC-IN chip, this is the small chip attached to the logic board that mounts the charging connection port that you connect your magsafe to, if you are confident and your machine is out of warranty, this can be purchased off the internet for ~$30 but the logic board must be removed to detatch this chip. DO NOT ATTEMPT THIS IF YOU DON’T KNOW WHAT YOU ARE DOING, YOU COULD VERY LIKELY DESTROY YOUR COMPUTER PERMANATELY.
      -The final problem being the most serious is a faulty logic board, if you have exhausted the above options, this is more than likely your problem and I would suggest you take it in to an apple repair centre for a repair quote.

      • danielsaidi 7:26 pm on November 10, 2011 Permalink | Reply

        Great comment – thank you for posting it! The strange thing for me was that the MB received power, but failed to load the last percentage…or rather, once the load progress reached 100%, the color toggling started. Hopefully, others with the same problem will find help solving it with your answer.

  • danielsaidi 8:31 pm on January 27, 2010 Permalink | Reply
    Tags: macbook, macbook battery,   

    MagSafe toggles green/orange 

    In my last entry, I wrote about all my problems with my MacBook (strangely though, this computer is by far the best I’ve ever had…which says a LOT about PC:s 🙂

    The last problem in the long list was that my battery swelled and had to be replaced. So, instead of buying a new Apple battery for about $190, I found a web site that sold “unofficial” batteries for almost half the price. Nice!

    After installing the new batteri and calibrating it, I was confused to see that my MagSafe adapter started to toggle between orange (loading) and green (loaded) although the battery IS fully loaded. The indicator reaches 100%, drops to 99% and goes on like this…on and on. So, I received a replacement battery and installed and calibrated it, but the problem remained.

    The way I thought, the problem could be either:

    • The replacement battery (two in a row = unlikely)
    • The battery together with my computer model
    • My MagSafe adapter
    • My computer’s battery connection (due to the swollen battery)

    However, if my battery would be loose, it would not be able to load…so…strike out the last alternative.

    To investigate this further, I took my computer to a friend of mine and installed the battery in her MacBook, where it worked like a charm…see below:

    • Her computer, MagSafe and battery = OK
    • Her computer and battery, but MY MagSafe = OK
    • Her computer, but my battery and MagSafe = OK

    So, this did not seem so promising…but when I re-installed the battery into MY computer, using MY MagSafe…it suddenly worked! Baffled (yet lucky), I returned home, where everything continued to work…

    …for a while. After two hours or so, the indicator started to blink once again! It still does so, so I am once again stuck with a MacBook component that does not work.

    If we boil this down to a summary, the battery seems OK, since it worked in my friend’s computer. However, so did the MagSafe, but…….is it possible that the MagSafe is damaged and that it happened to be “not loose” when I tried it out at my friend’s place?

    I will call another friend and ask him to come over with his MagSafe. If it works, it seems like I have to go to the place where I bought my computer and keep on struggling with this odd odd ODD MacBook example.

     
    • Johan 7:50 am on January 28, 2010 Permalink | Reply

      I was confused by your sudden change av språk.

      • danielsaidi 8:00 am on January 28, 2010 Permalink | Reply

        Ha ha ha, seems like I left a residue from the opinion I wrote on the reseller’s web site 🙂 Thanks for noticing!

  • danielsaidi 7:15 pm on January 27, 2010 Permalink | Reply
    Tags: macbook, swollen battery   

    MacBook – swollen battery 

    I have previously written about my numerous problems with my white MacBook, which I purchased in August 2007.

    For instance:

    • the fan roared like a truck
    • the audio out port shone with a red light and thought that I had plugged in an optical device (which I had not), which turned of all sounds from the internal speaker
    • the chassi cracked(!)
    • the color wheel of death appeared every now and then, freezing the computer
    • the computer stopped waking up from sleep
    • the computer stopped recognizing my hard drive and displayed a ? when booting up

    Fortunately, I had documented all these problems with pictures and videos and written a long issue report, which I intended to give to the reseller (in hope of a replacement computer). When the last problem occured, I was very glad that I had taken this step. The support person I gave the computer to doubted that I would get the errors accepted as a reclamation, but when I handed him the report, he said that it improved my chances drastically.

    And so it did…obviously, since I got the computed repaired. After that, it has worked like a charm…

    …until the battery swelled.

    I did not notice it at first, but after a slight bump in the battery, things quickly became worse, and before I knew it, the battery stood out quite a bit from the computer. Apple did NOT accept this complaint, so I had to buy a new battery. Luckily, I found a reseller that sold unofficial batteries.

    Still…(suprised that the problems keep washing over me?)…the new battery did not work as I had hoped. I will write about this in the next entry…the green/orange color toggle problem.

     
c
Compose new post
j
Next post/Next comment
k
Previous post/Previous comment
r
Reply
e
Edit
o
Show/Hide comments
t
Go to top
l
Go to login
h
Show/Hide help
shift + esc
Cancel